Daydream Blue
Daydream Blue

Bugs in latest update

The latest update includes a "fetch all" option, which correctly appeared when I started a NEW adventure. When continuing an adventure, however, (one in which I already had the robot), my robot was lifeless. His control box read, "Deliver robot," which, if I selected, caused the plane to fly over, but nothing ever dropped (presumably because I already have the robot, although now he is, as I said, lifeless). He just sits there with no movement and no eyes. It's quite creepy, actually. Hahah.

Also, in a new adventure over by the skipping stones, I notice if I throw a log on the land around me, it produces a "splash" effect as if I had thrown it i to the water.


  • I forgot to mention the "fetch all" option does not appear in the continued adventure with the lifeless Ralph.
  • Huh...Have you tried feeding Ralph? I ma not sure if there is a bug or he is just starving?!?
  • I tried feeding him. No effect.

    It turns out that he does have eyes, though. I didn't notice them at first because he is turned facing away from me toward the mountains. (He's currently parked near the fire pit, directly behind me, if I am facing the water.)

    Incidentally, I've intentionally starved him in the past. His behavior gets quite comical! (Good job!)

    When I resumed my game, I also somehow started inside of a cloud. (The cloud was at ground level.) Or is that supposed to be the "snow" weather? (How can I help activate snow, by the way?)

    Sorry, I don't mean to overwhelm you. Just helping you QA. It's still fun!
  • re: the ground-level cloud. When I resumed my game, it placed me in the tree area, between the firepit and the rock skipping areas. I was disoriented by a massive shroud of white, so I teleported over to the firepit, and when I looked back at the spot I was just in, there was very clearly a large, white cloud gliding across the land and into the mountain.
  • Okay, I am pretty sure I know what happened, and with your description we should be able to track it down.Thanks so much for letting us know! And for giving us such a detailed description. Hopefully we can do a quick fix in the next few day.
  • Hi Jason. We are looking into the bug you found. You don't happen to still have that save file do you? If so, if we can get the file we can figure out what happened.

    If you still have the save:
    Connect Phone to computer over USB
    Go to phone, navigate to Phone>Android>data>com.RalphVR.daydreamblue>fiIes - inside here are XML files. If you can send these to us, we greatly appreciate it! Send them to

    If you deleted the save, no worries :)
  • Hello!

    I was recently in in multiplayer mode and made a purchase for my house, but when I exited back to single player mode it wasn't in my house, but my monies were gone. Not a big deal as I just bought it again in single player mode, just a note for you. Also, my tent disappeared the other day and I had to buy another one, just wondering that happens or if it was a bug of some kind too. Keep up the good work, love the experience in there. Wish I could find a room in multi player mode that had someone in it though....
  • The issue with buying items in Multiplayer is an issue we are working to fix. By design the changes to the world in multiplayer are not saved when returning to single player. The problem is what to do about money. We are trying to find a solution, thanks for letting us know that it happened to you :)

    The tent disappearing seems weird. Never heard of that before. It is possible it somehow got knocked into the water or something. Although that seems unlikely. You can always tell Ralph to fetch all of the items and see if he brings it back!

    Yeah, we are having trouble getting enough people playing Daydream Blue to have a lot of people in multiplayer. One thing we have talked about is putting a version on Oculus Share, to try and get more people playing across the devices. Until then, the best bet is to try here, or the gearvr subreddit, or twitter, to find people to play with. Sorry we don't have a better answer :( Hopefully soon!
  • I'll try the fetch all again and see what happens. Hopefully the app catches on, maybe after some more publicity we can get more people in there.
  • Hopefully! Not sure if you use reddit, but the r/Oculus and r/GearVR subreddits might be a good spot to try and post about joining a multiplayer room as well. Hopefully on our end we can get some Oculus users in multiplayer in the next few weeks! Thanks for being patient!
  • Bugs!!!
    First off let me say that this is one of the coolest apps on Gear Vr. It has so much possibility, its so peaceful and immersive.. The only app that I actually knock over furniture in my house with - so immersive I lose myself. Amazing. 

    Ok bugs.. Last night my dart recipe was listed at 0. And my gun stuck at zero. I had to make a new one this morning to be able to play darts again :(

    I met another player last night. He was talking about how he has like 30k monies. He tried to buy stuff for me but instead it permanently removed my money (did not come back after I left multiplayer). So it spent both his and my money permanently. Waaaah! 

    This morning my house was missing. I had to fish a new one.  I bought a new recipe and made a new gun. Then I went to multiplayer. Noone was there... I earned some more monies and filled my house with furniture. When I left multiplayer, my money was gone and my furniture too.  :( waaaaaah! 

    Hope these are helpful. The dude I met last night told me that you can speak to us omniously from the sky, hahaha I gotta see that. Maybe you can rain some of the monies that got ganked from me upon my humble self. hahahah. 

    • In real golf (2 player) whoever won the last hole goes first... 
    • Music box - access our phone music... 
    • Expand! More games, bigger world. 
    This is a great app. Ill tell my friends. 

  • Heya Doublehead,

    Thanks for the feedback. So the issues with multiplayer are not bugs in the code, just bad design on our part. The problem we are facing is how to handle items purchased in Multiplayer because we don't save the multiplayer world once people leave it. i.e. the ideas you bought were never really saved anywhere, so you lose them. We tried adding in info about this when players join online, but that is not working. We are working on a solution but...

    Recently Oculus required all games to now support Mobile SDK 1,0. The problem is that in order to use SDK 1.0 we have to upgrade the Unity Engine, and when we do this we have a host of problems with performance. We are trying to figure it out, but so far Oculus and Unity just tell us what we already know, and we don't understand why our game goes from 60 FPS to 30FPS with an upgrade that is supposed to improve performance?!?

    This is why we have not updated in awhile. We are building a ton of new content, but we are kinda bottlenecked right now with upgrading everything.

    Hopefully we can solve this soon as we want to address the bugs and issues people such as yourself have taken the time to let us know about.

    Anyway, tl;dr, trying to solve problems with required upgrade so we can update with new stuff and try to better design multiplayer.

    Thanks for your feedback!

  • Welcome! BTW I have referred and gotten at least 4 people so far to buy your app. Bummer that its got low stars, that scares people away. But I tell them about it and they go buy it. Rock. Gotta get you funded so you can keep going, this app is great. 
  • ill make sure and rate it properly
  • Thanks Doublehead! We are working on a new update right now for more too add to the game. We had some tech issues but hopefully we can solve them soon. Working on it at this very moment :)
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!